Virtual Intel 21140-Based PCI Fast Ethernet Appears To Reset, in Virtual Server 2005
ASP Developer Network - Brought to you by Steve Radich and BitShop, Inc. - http://www.bitshop.com

Menu

ASPDeveloper.Net / VirtualServerFAQ.COM

Make sure you go to our home page for:

* Virtual Server 2005 FAQ
* ASP.Net 2.0 Information
* ASP.Net 2.0 Streaming Tutorials
* ASP.Net 2.0 HTML based Tutorials

Made possible by Business Internet Technology Shop (BitShop)



View :  Show duplicate posts
Virtual Server 2005

Recent Virtual Server 2005 posts

CGI Application Misbehaved (new install)
Virtual Server as WebService?
How to Grand Permission to single User ?
Strange JavaScript Error on Admin Web Site running IE7 on XP SP2
Strange networking error in my VM
VM Networking problem
Debugging a hung virtual machine after the event (how to crash a hung VM)
3 problems -- Networking, Auto Startup of guests and VM host does
VM network problem
When install VS R2 Sp1 the msiexec encountered a problem
Issue while trying to deploy a Virtual Machine
DOS on Vitrual server
Unable to give VMRC keyboard focus after user log off in XP
Not switching to saved state on backup
Save/Restore crashes VS every time
Virtual Desktop on Virtual Server
X64 VM not working on 64OS
Virtual server 2005 question
Virtual Server 2005 R2 & MNS Cluster
Windows 200 Pro guest installation problem
Add Solution

Latest Topics

Table Of Contents


Post Reply |  This is Spam! | Mark as Spam

Virtual Intel 21140-Based PCI Fast Ethernet Appears To Reset

Source: microsoft.public.virtualserver
Sent: 10/22/2007
From: "Soquel Dude" <(email address - cut out)am>
Message:

Hi!

We have a Dell Optiplex 740 running VS 2005 R2. We run 10 virtual clients on
this desktop and perform tcp stress tests with iPerf over an NDIS 5.x IM
driver that we have developed.

Occasionally, we see what appears to be a reset of the underlying virtual
Intel 21140-Based PCI Fast Ethernet NIC on some clients. We see the
following symptoms:

1. Loss of received packet indications for 1-3 seconds.
2. A quick transition between media disconnect and media connect
indications. This transition usually takes no more that 32 ms.

Nothing is logged in the system event log for those clients that see this
behavior. However, the interval for the loss of packet indications seems to
imply the virtual NIC is requesting NDIS call its MiniportReset function at
the next invocation of its CheckForHang handler, which can be up to 2
seconds since the last invocation.

Has anyone seen this before with the virtual Intel NIC and does anyone know
of a way to trobleshoot this?

Better yet, is there anyway to debug this through WinDbg? Are the symbols
for the virtual NIC driver available?

Thanks!




Post Reply |  This is Spam! | Mark as Spam

Related Messages


Post Reply |  This is Spam! | Mark as Spam


Table Of Contents



Other groups

 
Virtual PC (Mac)(3580) Virtual PC(12826) Virtual PC (French)(488)
Virtual Server 2005(6234)
Search
in:
Our Sponsors
Virtual Server 2005 Info Here!
http://www.aspdeveloper.net
Virtual Server 2005 Info Here!
http://www.aspdeveloper.net
Virtual Server 2005 Info Here!
http://www.aspdeveloper.net
Virtual Server 2005 Info Here!
http://www.aspdeveloper.net
Virtual Server 2005 Info Here!
http://www.aspdeveloper.net
rss Wiki rss Blogs rss Articles rss Image galleries rss File galleries rss Forums rss Maps rss Directories
ASP Developer Network (since 1996) - Brought to you by Steve Radich and BitShop, Inc. - http://www.bitshop.com
Copyright © 1997-2005 by BitShop, Inc. All Rights Reserved.
No content may be reproduced in any form without written permission from BitShop, Inc.
We will be honored to assist with reproduction rights on our material if you contact us.
We also can provide print articles for your magazine, private training seminars at your site, and conference presentations.

Thank you for visiting. Please bookmark our site if you found it useful!
If you wish to make a donation it will help further the development of these free resources: